Ist die Handlungshilfe 4.0 unter dem Application Server JBOSS7.1 mit JAVA EE6 lauffähig?
mehr

Ja, siehe Informationen für die IT.
Ab JBOSS V4.1 und JAVA EE5 läuft die Handlungshilfe 4.0. Voraussetzung ist, dass der Application Server mit der entsprechenden JAVA Version kompatibel ist (darauf aufbaut).

2015 endet der Support von Java SE 7 durch Oracle. Ist die Handlungshilfe 4.0 auch mit Java 8 lauffähig?
mehr

Java 7 ist lediglich die Mindestvorrausetzung. Die Handlungshilfe 4.0 ist auch unter Java 8 lauffähig.

Hinweis: Die Handlungshilfe kann nur mit einer Java VM der Firma Oracle betrieben werden (vergleiche Punkt 3.1 der Installationsanleitung), da nur so eine einwandfreie Funktion gewährleistet werden kann.

Fehlerhafte Altdatenübernahme durch zusätzlich installiertes OpenJDK:
mehr

Bei der Altdatenübernahme treten zwei Fehler auf:

1. Arbeitsplaner, die den Baustein Schießlärm enthalten, können nicht migriert werden. Die Migration der Arbeitsplaner wird abgebrochen.
2. Wurde der Baustein vor der Altdatenübernahme entfernt, wird die Migration mit „Erfolgreich“-Meldung abgeschlossen. Aber in den Arbeitsplanern fehlen Inhalte, z. B. Dokumente im Dokumentenreiter oder der komplette Inhalt des Reiters Prüffragen.

Fehlerursache ist ein zusätzlich zum Oracle JDK installiertes OpenJDK in der Installationsumgebung Standard MINT Linux. Dieses zweite JDK verursacht beide Probleme der Altdatenmigration.
Die Handlungshilfe kann nur mit einer Java VM der Firma Oracle betrieben werden (vergleiche Punkt 3.1 der Installationsanleitung), da nur so eine einwandfreie Funktion gewährleistet werden kann. Nach Deinstallation des OpenJDK tritt das Problem nicht mehr auf.

Unter welchen Betriebssystemen läuft die Serverversion?
mehr

Die Serverversion der Handlungshilfe 4.0 wurde für folgende definierte Betriebssysteme (Referenzbetriebssysteme) getestet: ·

  • Windows Server 2008 R2
  • Ubuntu Linux ? 10.04
  • OpenSuSe Linux ? 10
  • SLES Linux ? 11
  • Debian Linux ? 6
  • Red Hat Enterprise Linux ? 5.1

Zusätzlich liegen folgende Informationen vor:

  • Die Installation auf einem Server mit dem Betriebssystem Windows Server 2016 ist laut Aussage der Entwicklerfirma prinzipiell möglich. Da das Programm nach unserem Kenntnisstand bisher nur auf einem Server mit diesem Betriebssystem installiert wurde, gibt es jedoch wenig Erfahrungswerte.
Unter welchen Betriebssystemen läuft die Einzelplatzversion?
mehr

Die HH 4.0-Einzelplatzversion ist insoweit unabhängig vom installierten Betriebssystem, als dass sie lediglich eine lauffähige Java-Anwendung (Java 6) und einen Web-Browser (mindestens HTML 4.2 und JavaScript) benötigt. Unterstützt das Betriebssystem diese Programme, läuft grundsätzlich auch die Handlungshilfe. Ändert Microsoft etwas an den Rahmenbedingungen zur Programminstallation (Benutzerberechtigungen, Schutz von Verzeichnissen oder eine Signierung der Installationsroutine), muss auch das Installationsprogramm angepasst werden.

Die Handlungshilfe 4.0 wurde für folgende definierte Betriebssysteme (Referenzbetriebssysteme) getestet:

  • Windows XP SP3
  • Windows Vista SP1
  • Windows 7
  • Windows 8: Es liegen keine Informationen vor. Prinzipiell sollte die HH 4.0 unter Windows 8 lauffähig sein.
  • Windows 10: Die Einzelplatzversion HH 4.0 2575 ist unter Windows 10 nicht lauffähig. Das Programm kann nach dem ersten Beenden des mitinstallierten Servers nicht mehr gestartet werden. Für Windows 10 müssen aufgrund anderer Sicherheitspolicies Erweiterungen eingepflegt und Einstellungen im Installationsverzeichnis geändert werden. Dies ist für das nächste Systemupdate bereits in Entwicklung. Derzeit besteht die Möglichkeit, von der Entwicklerfirma ISB kostenpflichtig ein Bugfix einspielen zu lassen, das das Problem für die Version 2575 behebt. Bitte wenden Sie sich dazu an handlungshilfenoSpam@isb-ag.de
Welche Browser können verwendet werden?
mehr

Folgende Browser sind sowohl für die Server- als auch die Einzelplatzinstallation erforderlich:
•Google Chrome ? Version 13
•Mozilla Firefox ? Version 6.x
•MS Internet Explorer ? Version 8
•Safari ? Version 4
•Opera ? Version 11

In den verschiedenen Browsern kann es zu Darstellungsunterschieden kommen. Darauf hat die Handlungshilfeanwendung keinen Einfluss.

Wie muss der Browser konfiguriert sein?

Die Browser müssen so eingerichtet sein, dass die Verwendung von Session-Cookies (siehe oben) und Java-Script für den Benutzer möglich ist. Einige Hinweise zu Java:

•? Oracle Java VM Java SE 6 Update 24
•? Oracle Java VM Java SE 7 Update 2

Zudem müssen die Seiten immer aktuell vom Server abgerufen werden können. Ein Offline-Modus wird nicht unterstützt.

Kann die Handlungshilfe auf einem Mac-Computer installiert werden?
mehr

Die Handlungshilfe 4.0 wurde nicht für den Betrieb auf Apple-PCs entwickelt. Prinzipiell ist die Version 4.0 aber auch auf einem Mac-Computer lauffähig.   Voraussetzungen für die Serverversion sind:

• unterstützte Web/Application-Server: JBoss ab Version 4.1, Geronimo ab Version 2.1.1, Oracle WebLogic ab Version 9.2, IBM WebSphere AS ab Version 6.2, Apache Tomcat ab Version 7.x, Jetty Version ab Version 6.1
•unterstützte SQL-Datenbanksysteme: Oracle ab Version 10g, MSSQL ab 2005, PostgreSQL ab Version 8.3, H2 ab Version 1.3.164
•Java7-Installation

Genauere Informationen dazu finden Sie in der Installationsanleitung. Der Installer der Einzelplatzversion wurde nur für Windows-Betriebssysteme konzipiert. Eine manuelle Installation sollte aber dennoch möglich sein.